Loading the content... Loading depends on your connection speed!

Magento 2: Instalación de Magento 2, en servidor CentOS 6.8, Plesk 12.5, PHP 5.4, y MySQL 5.1

Estos son los pasos seguidos para instalar Magento 2 en un servidor CentOS 6.8, Plesk 12.5, PHP 5.4, y MySQL 5.1 (Sirve también para otras versiones de Plesk)

1. Actualizar la versión de MySQL 5.1 a MySQL 5.5

Plesk Autoinstaller obtiene paquetes desde los repositorios base del sistema operativo instalado.
Si en el repositorio base no se muestra MySQL 5.5, este no estará disponible para Plesk Autoinstaller.
En este caso, para actualizar MySQL a la versión 5.5 será necesario configurar un repositorio de terceros.
En sistemas basados en RedHat puede utilizarse el repositorio de Atomic:

# wget -q -O - http://www.atomicorp.com/installers/atomic | sh
# yum upgrade mysql
# mysql_upgrade -uadmin -p`cat /etc/psa/.psa.shadow`

 

2. Actualizar la versión de MySQL 5.5 a MySQL 5.7

Detenga el servicio MySQL:

# service mysqld stop

Instale el repositorio MySQL-community:

# yum install http://dev.mysql.com/get/mysql57-community-release-el6-7.noarch.rpm

Instale los paquetes de MySQL:

# yum install mysql

Inicie el servicio MySQL:

# service mysqld start

Actualice las bases de datos MySQL:

# mysql_upgrade -uadmin -p`cat /etc/psa/.psa.shadow`

 

3. Instalar la versión de PHP 5.6 paquetizada por el equipo de Plesk

Vaya al interfaz de Plesk Installer y seleccione las versiones de PHP que necesita (“Añadir/eliminar componentes” > “Prestaciones de hosting web” > “Distintas versiones de intérpretes PHP”).
En el dominio que está instalado Magento 2 selecciones la versión de PHP 5.6 que acaba de añadir.

4. Instalar Magento 2 desde la sección de Aplicaciones de Plesk

Dentro del panel de control Plesk deberemos ir al menú de la izquierda para seleccionar la sección de Aplicaciones y dentro de la misma escoger la opción de “Todas las aplicaciones disponibles” para así poder poner en el buscador de Aplicación el nombre de la aplicación que deseamos instalar, en nuestro caso Magento. Y finalmente hacer click en Buscar.
Depende de nuestra instalación obtendremos una versión u otra, en mi caso instalé Magento 2.1.0.

5. Actualizar Magento 2 a la última versión con composer

Como he comentado en el punto 3, en lugar de actualizar la versión de PHP base del servidor para que funcione Magento 2, en su lugar recomiendo utilizar el soporte nativo de Plesk para múltiples versiones de PHP.

Sin embargo, al ejecutar composer todavía detectaba la versión anterior de php (php 5.4) ya que es el servidor por defecto.

La solución: Si utiliza composer desde la línea de comandos, debemos agregar la ruta correcta a php binario en PATH env:

Por ejemplo, suponiendo que el servidor tiene instalado de base php 5.5:

# php -v

PHP 5.5.9-1ubuntu4.11 (cli) (built: Jul 2 2015 15:23:08)

# which php

/usr/bin/php

But I want to use php 5.6 installed by Plesk:

# /opt/plesk/php/5.6/bin/php -v

PHP 5.6.13 (cli) (built: Sep 8 2015 11:53:39)

# export PATH=/opt/plesk/php/5.6/bin:$PATH
# php -v

PHP 5.6.13 (cli) (built: Sep 8 2015 11:53:39)

# which php

/opt/plesk/php/5.6/bin/php

 

Dejar un Comentario

Magento | Prestashop | Aplicaciones Web | Posicionamiento Web (SEO) | Marketing Motores Búsqueda (SEM) | Optimización Redes Sociales (SMO)